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Background Information for this Tutorial 
This tutorial will show the procedures of using GeoCadastre v2018 to prepare the SGLX for 

submission to CSMS for the allocation of new lot numbers. After that, the procedures to complete 

the processes for the submission of Certified Plan will be described. 

For this tutorial, a sample data set will be used. The parent lots are MK18-13738W and MK18-

13582P, which are to be amalgamated into Plot1. Then Plot1 will be further subdivided into Plots 2 

to 7. Please refer to the diagrams below. 

  

Get Lot Number (Allocation of lot numbers) 
This tutorial is for the purpose of preparing and submitting a SGLX for allocation of new lot numbers. 

Information required before proceeding: 

 Job number (SVY) from the Registered Surveyor’s Portal (RSP) 

 Any other supporting documents necessary in PDF format 

 SGLX of the parent lot(s) by using the Get Lot Information function in the RSP 

Steps: 

1. Launch GeoCadastre and click File > Save Project As... to create and save a new project. 

2. From the menu, select Tools > Import PO Data. Select the SGLX of the parent lot and click 

Open to import it into the PO Data section. 
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3. In the PO Data, Lots section, select the parent lots and click Copy Lots. This will copy the two 

parent lots into the RS Data section. You will be prompted to enter a starting station 

number. The default is 2001. Click OK to accept the starting number. 

4. Next we will export the parent lots into a CAD software to prepare the proposed lots.  

5. Click on the RS Data, Lots section. Select the two parent lots. 

6. From the menu, click Tools > Export RS Lots. Change the Save as type: to DXF, enter a 

filename and click Save to save a DXF file of the parent lots. 

 

7. Open the DXF file in CAD and construct the boundaries of Plots 1 to 7. Note that each plot 

has its own layer and each plot is constructed as a closed polygon. Save this new DXF file. 

This is how it should looked like in CAD: 

 

Screen capture showing the proposed lots as constructed in CAD with the layers 

8. Import the proposed lots DXF file into GeoCadastre by selecting from the menu, Tools > 

Import Design Data. 

9. Select the Design Data, Lots section. Select Plots 1 to 7, then click Copy Lots to copy the 

plots to the RS Data section. When prompted for the starting station number, click OK to 

accept the default. 

10. In the Map Legend, uncheck PO Lots and Design Lots to hide them. This should be what you 

are seeing. 
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Tip: The left-most boxes control the display of the geometries while the right-most boxes control the 

display of the labels for those geometries 

11. In the RS Data, Lots section, right-click in the Parcel Class box for Plot1 and change the value 

from “final” to “interim” as Plot1 is a dummy lot. 

12. From the menu, select File > Project Information... 

13. Enter the Job Information as needed. Select Get Lot Number from the (process) drop-down 

list, select Land Lot from the (lot type) drop-down list and the appropriate job type as 

needed. The Purpose of Survey code will be automatically generated. 

 

14. Click Surveyor Information and enter the necessary information as needed. 

15. Click on Lineage to fill in the history of subdivision. The lot numbers can be filled in by right-

clicking in the boxes and selecting the lot numbers from the drop-down list. 

 

16. Click on Physical Relation to fill in the necessary information. The lot numbers can be filled 

in by right-clicking in the boxes and selecting the lot numbers from the drop-down list. 
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17. Click OK after filling in all the necessary information and close the Project Information dialog 

box. 

18. In the RS Data, Stations section, amended the CgPoint ‘desc’ to allocation by selecting the 

whole column, right-clicking and then selecting allocation from the drop-down list. You may 

have to enable editing by clicking on Start Edit if the editing mode is disabled. 

 

19. From the menu, select Tools > Export Data for Submission to export the SGLX for 

submission in the RSP. 

Certified Plan Submission 
After the lot numbers have been allocated, an EXCEL sheet containing the lot numbers and their 

corresponding Plot numbers will be returned. A sample is as shown below: 

 

Before proceeding, obtain the CP number from the RSP. 

Continuing from the previous steps, we will import this EXCEL sheet into GeoCadastre and update 

the lot numbers. 
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1. From the menu, select Tools > Import RS Lot Schedule. Select the EXCEL file and click Open. 

A Load RS Lot Schedule dialog box appears, click Yes to update the lot numbers. 

 

2. Select RS Data, Lots section to see that the lot numbers have been updated. Enable editing 

by clicking on Start Edit and enter the CP number as obtained from the RSP. 

 

3. From the menu, select File > Project Information...  

4. Select Job Information from the Project Information dialog box. Fill in the commencement 

date and the completion date. For the Purpose of Survey, change the (process) to Certified 

Plan. 

 

5. In the Project Information dialog box, select Surveyor Certificate. Select CP from the 

Certificate Type drop-down list. 

6. Fill in the Survey Date. 
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7. Select Instrument Configuration. Fill in the instrument specifications as necessary. 

 

8. Select EDM Calibration. Click Add (from Excel). Browse and select the Excel file for the EDM 

calibration. Fill in the Certificate Number and the Date. Click Apply Changes.  

 

9. Select Lineage. Check and make sure that the plots now have the correct lot numbers. 

 

10. Select Physical Relation. Check and make sure that the lot numbers are correctly entered. 
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11. Click OK to close the Project Information dialog box. 

12. From the menu, select Tools > Import RS Data. Browse and select the .csv file for the 

traverse observations. Click Open to import the traverse data into GeoCadastre. 

 

13. From the menu, select Tools > Import RS Coordinates. Browse and select the .csv file 

containing the coordinates for the ISN markers. Click Open to import them into 

GeoCadastre. GeoCadastre will match the station number and populate the northings and 

eastings automatically. 

 

14. In the RS Data, Stations section, make sure that sheet is enabled for edit. Click Apply. 

15. From the menu, select Tools > 2D Transformation. This will perform a minimally constrained 

adjustment and compute the transformation parameters as well as the residues for each ISN 

marker. 
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16. From the menu, select Tools > Fully Constrained Least Squares Adjustment. The adjustment 

report will be displayed. 

17. From the menu, select View > Traverse Misclose. The Traverse Misclose dialog box appears. 

Click Refresh to compute and display the traverse misclose report for all the loops. 

 

Tip: Green texts indicate the results are within tolerance, red are out of tolerances. Blue texts indicate 

the current tolerances as stated in the C.S. directive. 

18. From the menu, select View > Check Angles Comparison. In the Check Angles Comparison 

dialog box, click Refresh to compute and display the results. 

 

19. From the menu, select View > Lots. In the Lots Area Report dialog box, click Refresh to 

compute and display the areas of all the lots. 
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20. From the menu, select View > Boundary Points. Click Search in the Boundary Points dialog 

box. GeoCadastre will search for all surveyed points around 30mm of all boundary points to 

find a match. The results will be displayed. 

 

21. In the Boundary Points dialog box, click Suggest Monument ‘state’. This will update the 

stations’ state following the criteria listed below: 

 

22. Click Yes to update the state. 

23. In the Boundary Points dialog box, click Save and Transfer PO Coordinates. The found 

boundary points’ coordinates will be transferred to the surveyed points and will be removed 

from the station list. Correspondingly, the lot definitions will be updated. 

24. In the RS Data, Stations section, make sure edit is enabled, change the CgPoint ‘desc’ to 

final. 
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25. In the RS Data, Stations section, make sure that all the “fixed” points have coordinates and 

the fixed column is checked. These will be the coordinates that will be written out to the 

SGLX instead of the adjusted values. 

 

Preparation of DXF file for Importing into GeoCadastre 
The following sections describe the procedures to prepare and import into GeoCadastre, the 

annotations, occupations and encroachments for the purpose of CP generation in the RSP. However, 

at the time of writing this tutorial, occupations and encroachments are optional and therefore, may 

be skipped. However, annotations are necessary. 

GeoCadastre will import DXF files containing any annotations, occupations and encroachments that 

are drawn to scale and in SVY21 coordinates system. 

All linear objects like walls, fence, etc are to be drawn as polylines. If they are closed objects, then 

they should be constructed as such. Due to the limitations of the landxml format, circular objects are 

not supported. Therefore, any circular objects must be constructed by two connecting arcs instead 

of a full circle. 

The following shows the layer naming conventions so that GeoCadastre will be able to recognise the 

objects to be imported. 
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Any layers with the prefix of anno, like anno-AbuttalLine will be imported as abuttal lines, layers with 

prefix of occ, like occ-fence, will be imported as fence and any layers with prefix of enc, like enc-wall, 

will be imported as encroachment of the wall. 

The screen capture below shows the typical layers in a DXF file: 

 

For occupations, the owning parcel’s lot number is a line of text placed at one of the vertices of that 

particular occupation. This text has to be the same layer as the occupation. 

 

The diagram above shows the building line (in green) with the owning lot numbers placed at one of 

the corner of the building polyline. In this example, this building is owned by three lots, MK18-

40003D, MK18-40004E and MK18-40005F. 

For encroachments, it is done similarly to occupations except that the lot numbers would be the lots 

that are affected by the encroachment and not the owning parcel. 
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The diagram above shows the encroachment as depicted by the red polylines. The lot MK18-16968C 

is being encroached upon. 

Note that the text style, heights and rotation is ignored by GeoCadastre during import. 

For annotations, the rotation angle for the texts is depicted by having a pair of coordinates denoting 

the starting and ending points for the texts. Thus the rotation angles of annotations are honoured 

during import into GeoCadastre. 

 

To import the annotations, occupations and encroachments into GeoCadastre, select Tools from the 

menu and then select the appropriate actions from the menu: 

 



                                                                   
 

Last updated on 19 April 2018  14 
 

Further actions are needed when importing encroachments into GeoCadastre. You may have to 

select the “code” that represents the features. 

 

Right-click in the Code boxes and selects the appropriate features from the drop-down list. If the 

feature that you want is not in the list, you can manually enter the feature in the box instead of 

picking from the pre-defined list. 

After you have determined the code, you can now define the Occupation Reference (occRef) by 

right-clicking in the box and selecting the occupation from the drop-down list. 

 

Once all the occupations, annotations and encroachments are imported and prepared in 

GeoCadastre, you can now export the completed SGLX for submission. 

From the menu, select Tools > Export Data for Submission.  

 

 

 

*********** End of tutorial ************* 

 

 


